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Unable to See Department List/Department sales in Mobile App

Updated over 2 weeks ago

Where does this issue occur?

Mobile app only
Main menu (top left) > Price Book > Add/Update Item or Manage Price Book or

Live sales > Merchandise sales data > Error "Oops! Sorry, there was an unexpected error."


Issue Description

When adding or managing price book items in the mobile app, the department dropdown list appears empty, even though departments are visible in the web app.

or

When trying to view the Merchandise sales or Department sales under Live sales menu from mobile app, no data shows up with an error on the top "Oops! Sorry, there was an unexpected error."


Root Cause

Department names in the web app contain:

  • Special characters

  • Leading spaces (before the department name)

  • Trailing spaces (after the department name)

These formatting issues prevent departments from displaying correctly in the mobile app.

Note: No special characters should be used under the department names.


Solution

Clean up department names in the web app by removing special characters and extra spaces. Once corrected, the department list will appear in the mobile app after logging out and back in.

Important: This issue can only be fixed through the web app on a computer.


Step-by-Step Instructions

  1. Open the web app and click the user profile icon (top right corner)

  2. Select POS Settings

  3. Navigate to the Departments tab

  4. Click the Filter icon in the top right corner to access department management

  5. Review each department name and remove:

    • Any special characters

    • Spaces at the beginning of the name

    • Spaces at the end of the name

  6. Click Update to save your changes

  7. On your mobile device, log out of the app and log back in

  8. Test by adding or managing a price book item—the department dropdown should now display correctly.


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